ヤマムギ

growing hard days.

*

Amazon Linux2(EC2)にEC-CUBE 4をインストール

      2021/06/06


こちらのHOMEお知らせ・コラムAmazon Linux2にEC-CUBE4.0.4をインストールする手順~1~
Amazon Linux2にEC-CUBE4.0.4をインストールする手順
を参考に、少し手順を変えて実行しています。

変えたポイントは以下です。
* セッションマネージャが使いたかったのでec2-userではなくssm-userで実行。
* composer2だとエラーになるのでcomposerのインストールでバージョン指定。

EC2とRDS

Amazon Linux 2
t3.small

Aurora Serverless (MySQL 5.7)
ACU 1~4
最初のデータベースでeccube作成

事前設定とEC-CUBEインストール

Rootに変更してタイムゾーン、文字コードの変更、モジュールアップデート

MySQLクライアントをインストールしてログイン確認

データベースの存在確認

Apacheインストールと自動起動

Apacheの設定

AddType application/x-httpd-php .phpを追記

AllowOverride NoneをAllに変更

PHP7.2と必要ライブラリのインストール

メモリサイズ変更

Apache再起動

Gitインストール

ssm-userをapacheグループに追加して、パーミッションの変更

ssm-userに戻る

composer 1.10.10インストール
Composer

EC-CUBEインストール

確認と初期処理

EC2のパブリックDNSに /ec-cube/ を付加してブラウザからアクセス。

管理画面が表示されました。
admin, passwordが初期状態です。

ログインしてパスワードを変更しました。

このあと、例えばALBを使ったり、ElasticIPでIPアドレスを固定化することで、DNSが変更となった場合も、EC-CUBE4ではドメインの設定は必要ないそうです。
私もEC2インスタンスを停止して開始してパブリックDNSが変わってもそのままアクセスできました。

Composer2 でインストールしようとしたときのエラー

実行時にエラー

Installing dependencies from lock file (including require-dev)
Verifying lock file contents can be installed on current platform.
Your lock file does not contain a compatible set of packages. Please run composer update.

Problem 1
– ec-cube/plugin-installer is locked to version 0.0.8 and an update of this package was not requested.
– ec-cube/plugin-installer 0.0.8 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 2
– ocramius/package-versions is locked to version 1.4.2 and an update of this package was not requested.
– ocramius/package-versions 1.4.2 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
Problem 3
– ocramius/package-versions 1.4.2 requires composer-plugin-api ^1.0.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
– ocramius/proxy-manager 2.1.1 requires ocramius/package-versions ^1.1.1 -> satisfiable by ocramius/package-versions[1.4.2].
– ocramius/proxy-manager is locked to version 2.1.1 and an update of this package was not requested.

ocramius/package-versions only provides support for Composer 2 in 1.8+, which requires PHP 7.4.
If you can not upgrade PHP you can require composer/package-versions-deprecated to resolve this with PHP 7.0+.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to askthem to support Composer 2.

PHPを7.4でやり直しても同じエラー
なので、Composerのインストールで元手順の1.10.10になるようにあわせました。


最後までお読みいただきましてありがとうございました!

【PR】 「AWS認定試験対策 AWS クラウドプラクティショナー」という本を書きました。

【PR】 「AWSではじめるLinux入門ガイド」という本を書きました。

【PR】 「ポケットスタディ AWS認定 デベロッパーアソシエイト」という本を書きました。

【PR】 「AWS認定資格試験テキスト&問題集 AWS認定ソリューションアーキテクト - プロフェッショナル」という本を書きました。

 - AWS , ,

ad

ad

  関連記事

既存のAWSアカウントをAWS Control Towerに追加

Account Factoryからは既存アカウントは追加できない? AWS Co …

Amazon Aurora Serverless 課金確認

Amazon Aurora Serverlessを使い始めてみましたの記事で書い …

AWS EC2でAMI(Amazon Machine Image)を作成しておく

前回まででひとまずRedmineを構築するところまで出来たので、念のためスナップ …

AWS Well-Architected フレームワークによるクラウド ベスト プラクティスのセッションを聞いたので自アカウントの環境を確認してみる

AWS Summit Tokyo 2017で「AWS Well-Architec …

Amazon S3オブエジェクトへのリクエストをCloudTrail, Athenaで識別

こちらCloudTrail を使用した Amazon S3 リクエストの識別に書 …

EC2インスタンスが到達不能になって復旧してMackerelで監視し始めた

きっとばりばり使っておられる方ならよくある事なんだろうけど、はじめて体験したので …

AWS Systems Manager AutomationでEC2の自動停止

Systems Manager Automationがない時代に、Lambdaを …

「AWS認定資格試験テキスト AWS認定クラウドプラクティショナー」を執筆いたしました

「AWS認定資格試験テキスト AWS認定クラウドプラクティショナー」という本の第 …

AWS Client VPNのクライアント接続ハンドラを試してみました

AWS Client VPNを設定しましたで証明書とかせっかく作ったので、いろい …

AWS DeepLens開封の儀

去年(2019年)7月にamazon.co.jpでDeepLens買えますやんっ …